[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: kppp problem

Still no luck with DNS on kppp:

> > 1) why the error "modprobe: Can't locate module ppp0"
> I'll leave this one to some SuperGuru that uses Redhat. :)

I guess no RedHat SuperGurus have read this?
I did add the line "alias ppp0 ppp_generic" to /etc/modules.conf, and that got rid of the modprobe error, but now I get a message that looks like this: 

Couldn't find interface ppp0: No such device
Kernel supports ppp alright.

> > 2) why no DNS, even though it's obviously getting picked up? (yes, those are the correct DNS servers)
> Is /etc/nsswitch.conf configured to look at dns?  There should be
> a line in there like this:
> 	hosts:          files dns

That line is present.

> Sometimes stuff like that gets messed up...  Try running "nslookup"

When I run nslookup with no args, it hangs.  I have checked both /etc/resolv.conf and /etc/ppp/resolve.conf and they are both correct.

> You might do a "route -n" and make sure that your default route is

Here's what is shows:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface UH    0      0        0 ppp0       U     0      0        0 lo         UG    0      0        0 ppp0

I can't remember if I mentioned it, but this is a straight-forth out of the box installation of Redhat 7.1.  I haven't touched anything yet; getting this to work is my first priority.  


   ___|o__\_____   derek wickersham  www.shamrock-media.com
...\( )______( )\          shamrock at mtco dot com