[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FGI Connect Scripts

Okay, here's the files that I use to connect to FGI. I've
noticed a number of really strange things in my interface
configurations for ppp0, and it's my opinion that their
dhcp configuration needs some tweaking. However, 
these worked for me, so if you need them give 'em a


1.) Login as root and Verify that your ppp package is 
installed. Each distribution has it's own methods for 
doing this so I'll refer you to your distro documentation 
for instructions. Remain logged in as root while you're
following these instructions.

2.) modify the file /etc/resolv.conf by adding FGI's
name server information. Here's what my resolv.conf
looks like:


3.) I don't use any GUI tools to dial up for me, so 
this step consists of entering, or copying the following
files to your /bin directory (you could really put these 
anywhere, but just make sure that paths in the script
point to the right areas - If you don't understand what
that means then just copy these to /bin). Make sure
to modify these by putting in the correct phone number
for your area, modem speed, and username as well:


/usr/sbin/pppd connect /bin/connect.sh \
     /dev/ttyS1 <modem speed> \
     crtscts modem defaultroute asyncmap 0 bsdcomp 15,15 \
     lock name <username> noipdefault ipcp-accept-local \
     ipcp-accept-remote noauth -detach debug 

-----end ppp-up.sh-----


/usr/sbin/chat -v -t 45 ABORT "NO CARRIER" ABORT BUSY \

-----end connect.sh-----

Make sure the execute bit is set on these files 
(chmod u+x ppp-up.sh). If not you'll have to type
sh ppp-up.sh to get it to run instead of just ppp-up.sh.

4.) Add your user information to /etc/ppp/pap-secrets. The
format of pap-secrets is:

<username> * <password>

5.) Now to dial up just open a terminal window under X and


and it should do it's thing. If it doesn't connect be sure to 
check and make sure you have the right username, phone
number, modem speed, and password in the above files.
If it still doesn't connect after that try fooling around with
the ppp-up.sh file and change/modify a couple of options
(you'll probably want to start reading man pppd at this point).

One last note, pppd must be run as root, so that means
that these scripts must be run as root also. If you don't
normally log in as root (and of course no one here does 
that =), then you will have to su to the root account before
you run ppp-up.sh

Well that should cover it. Enjoy.

Jason Burke

To unsubscribe, send email to majordomo@luci.org with
"unsubscribe luci-discuss" in the body.