[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Samba and Windows 2000

Thanks, Steve,
	If I run Share level security it works fine.  Your suggestion
did work.  I think I was trying to make it way too complicated, but I
guess that is how you learn.  After getting Samba set up again, I
started getting the message that I could not connect to the account from
this machine.  I did some researching at Samba.org.  If I run user level
security, then you have to set the EnablePlainTextPassword value in the
w2k registry to a 1 (true). (This is discussed at the samba.org site if
you go to search, and then enter the error message, just for others who
might be reading and having the same problem) This issue was also
discussed on the Microsoft site and apparently is a very common problem
with user security in the new windows programs when connecting to Samba.
By default Windows 2000 does not accept plantextpasswords.  

This was very frustrating.  I am running RedHat 7.1 and am very new.
About a week and a half now.  I did go to the newbie meeting in
Springfield, and everyone had only great things to say about you and

I would also like to document that for anyone else who is going to be
using Samba with RedHat 7.1, here is what I did to get SWAT to work:

In /etc/services, add the following line:
swat	901/tcp	# Samba Web Administration Tool

in /etc/inetd.d/swat, make the following change
disable = no

For the changes to xinetd and /etc/services to take effect, you restart
the xinetd startup script by typing this line:
/etc/init.d/xinetd restart

This is from the Linux 7.1 bible

I installed Linux 7.1 without the firewall option until I know what I am
doing with samba.  (This is one of the questions during the graphic
install process)

Thanks,  Ricky

-----Original Message-----
From: owner-luci-discuss@luci.org [mailto:owner-luci-discuss@luci.org]
On Behalf Of Steven Pritchard
Sent: Friday, July 13, 2001 3:21 PM
To: luci-discuss@luci.org
Subject: Re: Samba and Windows 2000

Ricky Bryce said:
> Is anyone running Samba on a Linux machine, and trying to access a
> from Windows 2000?  I have been working with this for 2 days, and I
> SWAT to work just fine, and I can see the Linux machine in Network
> Neighborhood, but when I double click the machine to get to the share
> level, I get a message that the network path is invalid.  I also tried
> this on an NT 4.0 machine and I get the same results.  If you have had
> the same problem, please let me know!  

I have samba set up on various systems being accessed from every
version of Windows from 95 on up.  Everything works great.

If you want user-level security, you will need to enable password
encryption on the samba side *or* hack the registry on every Windows
box.  (Find the file ENCRYPTION.txt in the samba docs for more

If you don't care about security (if the shares on a box are going to
be wide open), then it might be simpler to just set samba for
share-level security.

I've also found that it often makes life easier to force the samba box
to be the master browser by setting "local master = yes", "os level =
33" (or some higher number),  and "preferred master = yes".  (Set all
that, then restart samba.)  If you can see the box in the Network
Neighborhood browse list, this *probably* isn't a problem.

steve@silug.org           | Southern Illinois Linux Users Group
(618)398-7360             | See web site for meeting details.
Steven Pritchard          | http://www.silug.org/
To unsubscribe, send email to majordomo@luci.org with
"unsubscribe luci-discuss" in the body.

To unsubscribe, send email to majordomo@luci.org with
"unsubscribe luci-discuss" in the body.